Force GUAM to listen to IPv4 socket



  • Is it possible to force GUAM to listen to an IPv4 address? On my system (a Jiffybox provided by Domainfactory) GUAM listens to port 143 and 993 properly - netstat shows...

    tcp6 0 0 :::993 :::* LISTEN 4552/beam
    tcp6 0 0 :::143 :::* LISTEN 4552/beam

    It would be nice to have GUAM to listen to 0.0.0.0 as well. I had similar issues with MariaDB, but could modify the config, so MariaDB switched over to listening to IPv4 sockets instead.

    Does GUAM provide a setting to change the IP address it listens to?

    Thank you in advance!



  • To answer my own question...

    The IPv6 address range contains the IPv4 address range, so a socket listening to :::993 listens to 0.0.0.0:993 as well. Everything is fine though ;-)


Log in to reply