Cannot Log In To Web Admin panel



  • Assuming a password of 'test' set in set up, I cannot log in to <LOCALHOST>/kolab/webadmin with username 'cn=Directory Manager' and password 'test'.

    Troubleshooting info so far:

    <LOCALHOST>/kolab-webadmin/api/ returns '{"status":"ERROR","code":400,"reason":"Unknown service "}'

    kolab lm returns nothing

    service kolab-saslauthd status returns active(running)

    testsaslauthd -u cyrus-admin -p <password> returns 0: OK Success

    systemctl status dirsrv@kolab returns active(running)

    ldapsearch -x -D "cn=directory manager" -w test -s base -b "" "objectclass="* returns ... numResponses 2 numEntries 1 ...

    I am lost, and could use a pointer to a new direction to look in troubleshooting this thing.

    Thanks in advance



  • It seems your user "cn=Directory Manager" is setup correctly, because your ldapsearch works.

    Is there anything in /var/log/kolab-webadmin/errors?



  • [ERROR] (api) LDAP: Bind failed for dn=uid=kolab-service,ou=Special Users,dc=jonras,dc=home. Invalid Credentials


  • Global Moderator

    Does this not need to be cn= Directory Manager and not cn=Directory Manager



  • @JosW said in Cannot Log In To Web Admin panel:

    Does this not need to be cn= Directory Manager and not cn=Directory Manager

    unfortunately, that makes no difference in the outcome



  • @angryhippy said in Cannot Log In To Web Admin panel:

    [ERROR] (api) LDAP: Bind failed for dn=uid=kolab-service,ou=Special Users,dc=jonras,dc=home. Invalid Credentials

    See your /etc/kolab/kolab.conf, there are service_bind_dn and service_bind_pw in the [ldap] section.

    Did you modify something there?

    Perhaps you need to do a full clean install again?


Log in to reply