IMAP not syncing read status

  • Hi,

    I have Kolab 16.1 installed from Debian Repo running with a pretty standard setup (using Nginx instead of Apache).

    The problem I have is with IMAP connections and syncing the read status. I have clients using Webmail (Roundcube) and mobile on ActiveSync. When a new mail is received and opened on webmail or ActiveSync, the read status is copied to all devices (including IMAP) correctly, however when I open on an IMAP client (Outlook 2016, Apple Mail, Mailbird - all identical) it allows the mail to be shown as read on the client, but still shows as unread on ActiveSync and webmail.

    I have looked at the Guam logs and can see nothing obvious. IMAP clients are connecting through port 993 w/ SSL, whereas Roundcube is 143 but all through Guam.

    I have ruled out firewall issues by letting all traffic (TCP/UDP/ICMP etc) through and the status does not change, and the problem persists if people connect through the LAN or from WAN.

    Could anyone give me any pointers please as I end up with many many "unread" emails on my phone by the end of the day and its rather annoying my users



    P.S. This is a new install - I came from Postfix/Dovecot/Roundcube/Z-Push where these problems did not exist

  • I'm going to close this as the issue was not with Kolab.

    Seemingly my router did not accept a settings change without rebooting.

  • Reopening - seemed to be fixed however after 2 days it is back again

    Read status on IMAP not syncing. By the end of the day I have around 30-40 "unread" emails in Roundcube and on ActiveSync, but they are all read on the IMAP client.

    Could this be an issue with Guam?? Please offer any pointers


  • Kolabian

    It could be Guam. I'm observing strange issues related to \Seen flag in Thunderbird, but have no time to investigate. You could try to configure Roundcube (syncroton uses the same config) to use IMAP directly (that's port 9993 if I'm correct).

  • Thanks for the reply. Changing to 9993 (and then 993, rather than 143) breaks Syncroton. As this is production I need to do more debugging.

    Further info; I have 2 ActiveSync accounts (iPhone and iPad iOS10) if I read all on IMAP client, Roundcube and iPhone. It still remains unread on the iPad (even after forcing refresh/resync. The only error in Guam is (apart from a TLS error, but thats becuase someone tried to connect with TLS v1 and I only allow TLSv1.2:

    2017-04-02 07:41:31.710 [error] <0.24169.5> gen_server <0.24169.5> terminated with reason: no match of right hand value {error,closed} in kolab_guam_session:accept_client/1 line 129

    2017-04-02 07:41:31.710 [error] <0.24169.5> CRASH REPORT Process <0.24169.5> with 0 neighbours exited with reason: no match of right hand value {error,closed} in kolab_guam_session:accept_client/1 line 129 in gen_server:terminate/6 line 737

    2017-04-02 07:41:31.710 [error] <0.92.0> Supervisor {<0.92.0>,kolab_guam_listener} had child session started with {kolab_guam_session,start_link,undefined} at <0.24169.5> exit with reason no match of right hand value {error,closed} in kolab_guam_session:accept_client/1 line 129 in context child_terminated


  • Hello,

    i've got the same issue, no matter which client, Thunderbird, Roundcubemail, Outlook the read status is not sync for other users.

    In my project that is an extrem problem cause multiple people are working in on mails in a shared inbox.

    So it doenst matter if the mail address is a shared folder or a standalone account.

  • Can someone please give this some attention - it is driving me crazy. I've tried everything I can

    I have spun up a completely new VM with vanilla Debian 8 Jessie. I installed Kolab 16.1 from the repo and changed very little (mainly SSL certs) and nothing to do with Syncroton.

    I, unsurprisingly had the read flag issue again, so disabled Guam for Roundcube/Syncroton (changed in Roundcube to ssl://localhost:9993. This did not fix the issue

    So now I've completely disabled Guam (as I thought that was the issue), by stopping it and removing it as a service and starting Cyrus-imapd listening on port 993 and 143.

    All my clients can successfully connect (IMAP/Roundcube/Syncroton) but the read flag problem is still there! I'm therefore led to believe it must be an issue in Syncroton.

    I do have to say, I'm thoroughly disappointed with the package as a whole. I ran a postfix/dovecot/z-push hand built setup for two years and it ran without skipping a beat for two years. I have made the change to this as I want to hand some of the admin task to another person and I thought using a prebuilt package would be easier to administer as there would be guides, but as I've sadly discovered, most are woefully out of date and will break current configs.

    I'm not a sysadmin as a main role - I have a full time job in the company and this is additional so I really cant spend 9-5 debugging (its a live system with 6 users).

    Sorry for the bleeding heart but its incredibly frustrating that there seems to be no action on a massive issue (from a usability prospective) and it doesn't just seem to be me with the issue


  • As a follow up - disabling the account on iOS then re-enabling it syncs the read status correctly, surely there has to be a bug in Syncroton where the read status is not being pushed to the device unless it physically looks for it (e.g. when it repulls all the emails from the server) ?


  • Now the 389 service has crapped out for the second time leaving me with zero service...

    I'm out - this is a terrible product. I'm sorry but it truly is

  • Hi, when we tried the product, we gave up on debian after 2 days (two many trouble), the we restarted on Centos7 and it is a lot better, everything works out of the box. I've documented all the changes I had to do to suit our needs (I'll be happy to publish that if someone needs). But Debian (which is my favorite distro), I gave up very soon with Kolab.


  • Hello,

    so im using Centos in three locations, two productive and one testing system.

    On all three systems the read flag isnt working.

    No matter if its up2date or not.

    Tried several hints found in docs, looked at the logs but im out of ideas.

    Tried several reinstalls, tried stock, tried with messing around nothing.

    Maybe im more dumbish as i thing.

    So sibio, the read flags are working at your side?
    If so, maybe you can do a little support to point out the problem?

    Best regards Phil

    Dont get me wrong, i like the system and everything around but that read flag is driving me nuts.

Log in to reply