Guam still listing groupware folders



  • Trying out the new imap payload proxy with Thunderbird, I still see all groupware folders listed, not only the ones of type "mail". Is there something I need to configure specifically?

    Running guam 0.8-1.2.el7.kolab_wf from Winterfell packages, my etc/guam/sys.config already has the 'filter_groupware' ruleset:

    { port, 993 },
    { implicit_tls, true },
    { imap_server, imaps },
    {
        rules, [
            { filter_groupware, [] }
        ]
    },
    

    Also sending LIST, XLIST and LSUB commands from a simple PHP script reveals that there's no filtering happening.



  • I just connected Thunderbird using IMAP with two different accounts, one on port 143 with TLS and the other on port 993 with SSL. I had not run Thunderbird since Christmas, so I had to confirm a certificate change. Once I did, all the groupware folders disappeared. except for anything shared by another user. I can see shared groupware folders as "Other Users->(username)->Calendar" (or Contacts or Notes). Thunderbird version was 38.4.0, but it upgraded to 38.5.0, then 38.6.0.

    Under Outlook 2013, I never saw the groupware folders, not even the "Other Users" folders.

    However, I do see all the groupware and "Other Users" folders using Outlook 2003. What is interesting is that all the folders showed up in the list on the right side under the account, but if I queried the available folders from the server, I only saw the non-groupware folders. The only way I could get them to disappear in Outlook 2003 was to unsubscribe. Since Outlook 2003 doesn't support TLS, I had to use 993 with SSL.



  • I have been able to hide the folder in Outlook.
    Not sure how the correct names are in english as my Outlook is set to german.
    Right click on a Folder > Imap Folders and in this Window remove the small hook in the
    Setting show only subscribed Folder.
    With this setting all Groupwarefolders disappear.
    You can still see them when you change to the subscribed tab, but in the all-tab and in Outlook they are hidden.



  • @mhuetter said:

    I have been able to hide the folder in Outlook.
    Not sure how the correct names are in english as my Outlook is set to german.
    Right click on a Folder > Imap Folders and in this Window remove the small hook in the
    Setting show only subscribed Folder.
    With this setting all Groupwarefolders disappear.
    You can still see them when you change to the subscribed tab, but in the all-tab and in Outlook they are hidden.

    That's true, but the point of Guam is that it is supposed to selectively expose the groupware folders to clients that understand them, like Kontact and hide them from clients like Outlook without user intervention. Users with direct access to the groupware folders can really mess them up if they don't know what they are doing.



  • @troycarpenter , well so the only thing that is missing in guam is to hide also the subscribed groupwarefolders, so no overmotivated user can even see and unsubscribe them. I also tried it with thunderbird where it also seems to work as desired.



  • Made a test with Claws Mail in my VM and I can confirm what @bruederli says: no groupware folders are filtered.


  • Global Moderator

    Please see T1028


Log in to reply