Error while installing in Debian 8

  • Hi all,

    I'm trying to install Kolab on a Debian 8 chrooted system.
    I've been following the following guide:
    Then when I try to launch setup-kolab:

    (kolab)root@pc-front:~# setup-kolab --mysqlserver=
    WARNING: The Fully Qualified Domain Name or FQDN for this system is incorrect. Falling back to 'localdomain'.
    Running in chroot, ignoring request.
    Please supply a password for the LDAP administrator user 'admin', used to login
    to the graphical console of 389 Directory server.
    Administrator password [XXXXXXXXXXXX]: 
    Confirm Administrator password: 
    Please supply a password for the LDAP Directory Manager user, which is the
    administrator user you will be using to at least initially log in to the Web
    Admin, and that Kolab uses to perform administrative tasks.
    Directory Manager password [XXXXXXXXXXXX]: 
    Confirm Directory Manager password: 
    Please choose the system user and group the service should use to run under.
    These should be existing, unprivileged, local system POSIX accounts with no
    User [dirsrv]: kolab-server
    Group [dirsrv]: kolab-server
    This setup procedure plans to set up Kolab Groupware for the following domain
    name space. This domain name is obtained from the reverse DNS entry on your
    network interface. Please confirm this is the appropriate domain name space. [Y/n]: Y
    The standard root dn we composed for you follows. Please confirm this is the root
    dn you wish to use.
    dc=mydomain,dc=com [Y/n]: Y
    Setup is now going to set up the 389 Directory Server. This may take a little
    while (during which period there is no output and no progress indication).
    An error was detected in the setup procedure for 389 Directory Server. This setup
    will write out stderr and stdout to /var/log/kolab/setup.error.log and
    /var/log/kolab/setup.out.log respectively, before it exits.
    (kolab)root@pc-front:~# cat /var/log/kolab/setup.out.log
    Could not import LDIF file '/tmp/ldifQ21CEQ.ldif'.  Error: 256.  Output: importing data ...
    Error - Problem accessing the lockfile /var/lock/dirsrv/slapd-kolab/lock
    [10/May/2017:11:43:54 +0000] - Shutting down due to possible conflicts with other slapd processes
    Error: Could not create directory server instance 'kolab'.
    Exiting . . .
    Log file is '/tmp/setupG78y0A.log'

    Looking up on the Internet I already checked:

    • No other slapd instance (either on chroot environment of host)
    • Playing with /var/lock/dirsrv/slapd-kolab/ permission doesn't help
    • Using default dirsrv user and group doesn't help either...

    So I'm kind of stuck now. Would you have any suggestion?


  • Kolabian

    I don't know why it fails, but it fails on this command:;c76537295c900d30046b5655c76d503a2be87450$339 Maybe executing it by hand or with other arguments would reveal more info.

    I think this setup-ds program is not a Kolab code, but belongs to 389DS, so asking on their forum/list could help.

  • Hi,

    As written several time in this forum, I strongly advised you against Debian (I'm a Debian user myself), use CentOS 7 for Kolab. The install works out of the box.


  • Kolabian

    Yup, but the problem here might be chroot, not Debian itself.

  • Hi guys thanks for your answer. So that specific problem was related to 389 not working with different user for different config. I solved it by deleting all folders related to it, even log.
    That being said. Yes the install is unusable on debian.
    I moved from chroot to systemd-nspawnd container and installed a centos system on it.

  • how can I mark this as solved?

Log in to reply