Problem with freebusy on Ubuntu 16.04 / Kolab 16



  • Hi,
    I've just installed Kolab 16 on an otherwise 'empty' Ubuntu 16.04 freshly installed server. After running setup-kolab not everything was working well. I especially had to change the IMAP configuration in /etc/kolab/kolab.conf and /etc/roundcubemail/config.inc.php to use 'imaps' and cyrus-imap to actually use port 993 (it used 9993). After that, everything seems to work well except freebusy - I keep getting errors in /var/log/kolab-freebusy/errors:

    [09-Oct-2017 08:56:37 Europe/Berlin] PHP Fatal error: Class 'Sabre\VObject\Property\Text' not found in /usr/share/roundcubemail/plugins/libcalendaring/libvcalendar.php on line 1422

    After some googling, I found that maybe autoload.php might be missing from /usr/share/roundcubemail/vendor but this is actually there:

    root@Kolab:~# ls -l /usr/share/roundcubemail/vendor/
    total 12
    -rw-r--r-- 1 root root 183 Aug 27 15:27 autoload.php
    drwxr-xr-x 2 root root 4096 Oct 7 17:47 composer
    drwxr-xr-x 3 root root 4096 Oct 7 17:47 roundcube

    Sabre/VObject seems also to be installed:

    root@Kolab:~# dpkg -l sabre
    Desired=Unknown/Install/Remove/Purge/Hold
    | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
    |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
    ||/ Name Version Architecture Description
    +++-===============================-====================-====================-====================================================================
    ii php-sabre-dav-2.1 2.1.11-1 all WebDAV Framework for PHP
    ii php-sabre-event 2.0.2-3 all lightweight library for event-based development
    un php-sabre-http <none> <none> (no description available)
    ii php-sabre-http-3 3.0.5-3ubuntu1 all library to ease the work with HTTP protocol
    ii php-sabre-vobject 2.1.7-1ubuntu1 all library to parse and manipulate iCalendar and vCard objects
    ii php-sabre-vobject-3 3.5.3-2 all library to parse and manipulate iCalendar and vCard objects
    root@Kolab:~#

    Any hints/ideas?
    Jörg



  • Hi,

    I run into the same problem @joergh described above.
    Further, I was able to locate the missing class Class 'Sabre\VObject\Property\Text' in '/usr/share/php/sabre21/Sabre/VObject/Property/Text.php'.
    Unfortunately, my attempts to add it to '/usr/share/roundcubemail/vendor/autoload.php' resulted in internal errors.
    So, I am not sure if the class is actually loaded by php.

    If anyone has further ideas how to investigate this problem, please let us know.

    Best regards,
    Kevin


  • Kolabian

    Kolab-freebusy does not use Roundcube autoloader. From what I see its autoloader expects Sabre-VObject in /usr/share/php/Sabre/VObject/. So, make sure it's there and that it's version 3 not 2.1.



  • Hi @alec ,

    a symlink in /usr/share/php/Sabre/VObject/ solved the issue.

    Than you,
    Kevin


Log in to reply