Email transport fails after Kolab upgrade 3.3.6 -> 3.4.0



  • After upgrade via yum today (no issues during the update, went smooth without error messages et.al.),
    the email transport fails on every mail that is processed.
    Looks like cyrus is contacting amavisd for virus checking, but can't connect to a specific port (10026):

    Output from postqueue -p shows:
    E9C7B42BA4DF 743 Sun Oct 7 10:37:00 name@domain.de
    (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10026: Connection refused) name@mydomain.de

    Output from 'netstat -tupan | grep LISTEN' shows:
    tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN 3701/master
    tcp 0 0 0.0.0.0:4190 0.0.0.0:* LISTEN 1073/cyrus-master
    tcp 0 0 0.0.0.0:8000 0.0.0.0:* LISTEN 1746/python2.7
    tcp 0 0 127.0.0.1:10024 0.0.0.0:* LISTEN 3259/amavisd (maste
    tcp 0 0 127.0.0.1:10025 0.0.0.0:* LISTEN 3701/master
    tcp 0 0 127.0.0.1:27017 0.0.0.0:* LISTEN 1163/mongod
    tcp 0 0 127.0.0.1:9993 0.0.0.0:* LISTEN 1073/cyrus-master
    tcp 0 0 0.0.0.0:3306 0.0.0.0:* LISTEN 1534/mysqld
    tcp 0 0 0.0.0.0:202 0.0.0.0:* LISTEN 1037/sshd
    tcp 0 0 127.0.0.1:10027 0.0.0.0:* LISTEN 3701/master
    tcp 0 0 0.0.0.0:587 0.0.0.0:* LISTEN 3701/master
    tcp 0 0 0.0.0.0:4369 0.0.0.0:* LISTEN 706/epmd
    tcp 0 0 127.0.0.1:8082 0.0.0.0:* LISTEN 1455/seaf-server
    tcp 0 0 79.133.37.111:53589 0.0.0.0:* LISTEN 1065/taskd
    tcp 0 0 0.0.0.0:40501 0.0.0.0:* LISTEN 626/beam
    tcp6 0 0 :::25 :::* LISTEN 3701/master
    tcp6 0 0 :::443 :::* LISTEN 1041/httpd
    tcp6 0 0 :::4190 :::* LISTEN 1073/cyrus-master
    tcp6 0 0 :::993 :::* LISTEN 626/beam
    tcp6 0 0 :::389 :::* LISTEN 1087/ns-slapd
    tcp6 0 0 ::1:10024 :::* LISTEN 3259/amavisd (maste
    tcp6 0 0 :::202 :::* LISTEN 1037/sshd
    tcp6 0 0 :::587 :::* LISTEN 3701/master
    tcp6 0 0 :::143 :::* LISTEN 626/beam
    tcp6 0 0 :::8080 :::* LISTEN 1361/node
    tcp6 0 0 :::80 :::* LISTEN 1041/httpd
    tcp6 0 0 :::4369 :::* LISTEN 706/epmd

    Tried to debug amavisd output, but that's too complex for my mind...
    Temporary disabled content checking with
    postconf -e 'content_filter ='
    and - after restarting the processes involved - that circumvented the issue.
    But obviously, I can't run my server with content checking disabled.

    Did anybody else run into this issue? Is there any config change I needed to do manually, and missed?
    I am grateful for any help.


Log in to reply