Install Kolab 16 on Plesk 12.5 possible?

  • Hi there,
    i was unable to get Kolab 16 running under an Plesk 12.5 Virtual Server on CentOS 7.
    The install went fine so far after replacing php-mysql with php-mysqlnd.
    But the setup was not possible to get access to the MariaDB because Plesk renames the mysql root account to admin and i couldnt find a way to tell Kolab to use admin instead of root.
    Is there a way to tell the setup to use admin as the mysql user?

    Thanks in advance for any help.

  • You could just add new MariaDB user "root" with full access.
    Or you could change Kolab installation script.

    But i don't understand why do you need Kolab with Plesk together. I never used Plesk, but i think you could not get full integration. Or it will be long-long way. According you question you are not good in Linux/linux services. But if you want just install Kolab on same VM as Plesk - ok.

  • I already tried to add root user with full access but didnt work.
    Where do i find that installation script? Already tried to find it but without luck.

    Full integration is not needed, its more that i want to run Kolab as a collaboration suite under a subdomain and use Plesk for other websites hosting configuration.

    You are right, I am not a Linux pro (yet ;)) but wanted to try it anyway as Kolab looks really good and fresher than egroupware. ;)

  • Hmm. could you show kolab install logs?

    mysql setup script is here:

  • Well, i tried again and was able to install and configure.
    But now i have a Smarty problem when trying to access kolab-webadmin i get the following message

    Class 'Smarty' not found in /usr/share/kolab-webadmin/lib/kolab_client_output.php on line 69

    I am on Apache 2.4 with PHP-FPM 5.6.21

  • Got Smarty working but now

    class 'http_request2' not found in /usr/share/kolab-webadmin/lib/kolab_client_api.php on line 59

    Damn, thats a tricky one.

  • Hmm, i thought it might be a problem of missing pecl_http and installed it but this didnt change anything.
    Any ideas?

  • # yum install php-pear-HTTP-Request2
    # service httpd restart

    but something goes wrong, if you have this error.
    Could you look kolab install log?

  • Hi Constin,
    i was able to install the missing modules.
    Could it be that the nginx configuration is outdated or not working with nginx php-fpm in front of apache?
    I am trying to get it running but without luck so far.

    The login to kolab-webadmin causes the following error

    PHP Fatal error: PHP Error: Login failed. Unable to decode response (POST)

    I think this is not working because of not working rewrite rules or of not working fastcgi_pass_header X-Session-Token

  • Kolab use Apache by default. Try to map apache to another port ( for example 8080) and test kolab admin app with this port. If it works you could try use nginx as front-end or main web server for kolab. I mean that it requires step-by-step solution and finding problems. Because kolab imho is very moody.

Log in to reply