Kolab 16 Winterfell on Ubuntu 16.04 - Dependencies



  • I'm in the process of building a new mail server, and I recently had to switch solutions and found Kolab. I'm using Ubuntu 16.04 and am running across some of the same problems you all are. Specifically, I can't seem to get irony installed.

    The following packages have unmet dependencies:
    irony : Depends: php-sabre-dav (>= 2.1.3) but it is not going to be installed.
    Depends: php-sabre-vobject (>= 3.2.4) but 2.1.7-1ubuntu1 is installed.

    I installed php-sabre-dav and php-sabre-vobject through composer (per their website instructions), but the kolab install isn't recognizing that they exist.

    Any thoughts?



  • Hey guys, I have no clue, why this topic is marked as "solved". On ubuntu 16.04 its still impossible to install kolab. Did I missed any practical way to get it running right away?

    I stuck at mark.walkers point, dependencies for php-sabre-dav and php-sabre-vobject unsolved.



  • https://github.com/swig/swig/issues/571: Support for PHP7 has been merged into the master of SWIG!

    Anyone up for building SWIG from master, and see if that works for Kolab on Ubuntu 16.04 with PHP7?



  • @timotheus said in Kolab 16 Winterfell on Ubuntu 16.04 - Dependencies:

    https://github.com/swig/swig/issues/571: Support for PHP7 has been merged into the master of SWIG!

    Anyone up for building SWIG from master, and see if that works for Kolab on Ubuntu 16.04 with PHP7?

    How would one do that?
    First build SWIG and then use this rebuilt version of it to completely rebuild Kolab?
    I assume the switch from PHP5 to PHP7 would need to be specified somewhere, right?

    Sorry, I'm completely new to Kolab, but want to get it up and running on Ubuntu 16.04 :-)



  • I have now tested this for Fedora 25, which also comes with PHP7.

    I have rebuilt swig, using the srpm from Fedora, and then included the latest tar.gz from https://github.com/swig/swig/
    Here are my changes to the swig package for Fedora 25:
    https://github.com/TBits/lbs-kolab/commit/1c05d3539a332f61d12a3ffe06639ed9483544c5

    Then I had to apply a couple of fixes to libkolab and libkolabxml, to use swig with the parameter -php7: https://github.com/TBits/lbs-kolab/commit/5e3f6ac43e5cf350af4c2802b2f2613e132f0f13

    Now I can build libkolabxml and libkolab on Fedora 25.
    Next step would be to do that in OBS. I have now enabled Kolab Winterfell for Fedora 25, but that does not have had any effect yet, as far as I can see.

    @Schrubbi: you can try to do the same for Ubuntu. Get the original swig package from http://packages.ubuntu.com/xenial/swig, and build it with the latest tar.gz from git master. And then rebuild libkolab and libkolabxml, using similar fixes than I did for Fedora.



  • I have tried to build all packages of Kolab 16 for Fedora 25, but found a segmentation fault when building iRony, because it uses PHP 7 will the kolab modules (generated with swig) installed. Even php --version fails.

    A workaround is to use export USE_ZEND_ALLOC=0, but I don't know if that is what we want.

    So I guess there are still issues with swig for php7, but I don't know how to corner them to report them properly.



  • A problem with swig was fixed (https://github.com/swig/swig/issues/859). It seems the problem also existed for PHP5, and it was fixed there as well. I wonder if that would solve our legendary bug 2050... (you know that a bug has been annoying when you know the number in your head...).

    I have now working packages of Kolab 16 for Fedora 25: http://www.pokorra.de/2016/12/kolab-16-for-fedora-25/

    I hope this helps getting Kolab ready for Ubuntu Xenial as well...



  • I'am currently trying to setup a local Kolab-Server and a little bit confused how to proceed. The official repository (http://obs.kolabsys.com/repositories/Kolab:/Winterfell/Ubuntu_16.04/) still overs packages depending on php5. Rendering the whole apt-get part useless.

    Are there any Testbuilds with php7 dependencies.


  • Kolabian

    BTW, Kolab 16 (not Winterfell) installs on Ubuntu 16.04 since last weekend.



  • Confirm. Installation works fine now ...



  • A little hint. The current Winterfall and Kolab 16 packages missing a dependency on the pymysql package. This isn't detectable because all runs well, until you try to send a mail from a "remote client" and the /usr/lib/postfix/kolab_smtp_access_policy exits with status 1 (unable to load pymysql).

    after manually install the python 2.7 /3 (just in case) pymsql module all works fine



  • I thought the issue with pymysql was fixed 12 days ago in Kolab 16: https://obs.kolabsys.com/request/show/2060
    and in Kolab Winterfell even earlier:
    https://obs.kolabsys.com/package/rdiff/Kolab:Winterfell/pykolab?linkrev=base&rev=35
    and https://obs.kolabsys.com/package/rdiff/Kolab:Winterfell/pykolab?linkrev=base&rev=36

    Perhaps my change only works for installing the package the first time, but not for an upgrade, if python-mysqldb is already installed, then python-pymysql is not installed. But I needed to write python-pymysql | python-mysqldb because Debian Jessie does not have python-pymysql, and I did not want to have two separate debian.control files for Debian and Ubuntu.



  • I've testes it on Thursday 8.6. It was a fresh ubuntu but postfix was installed already. On Monday 5.6 the same error occured with a clean installed Ubuntu (without postfix installed)