Managesieve problem after securing server



  • Hello!
    I use Kolab 16 on Centos 7.
    After securing my server with Let's Encrypt i've got an error message on opening filters and vacations in my roundcube settings.
    There is error in /var/log/roundcubemail/errors:

    [13-Jul-2016 20:51:03 UTC] PHP Warning: stream_socket_enable_crypto(): SSL operation failed with code 1. OpenSSL Error messages:
    error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number in /usr/share/pear/Net/Sieve.php on line 1227
    [13-Jul-2016 20:51:03 UTC] ERROR: Failed to establish TLS connection (2)
    [13-Jul-2016 20:51:03,539700 +0000]: <i1bilpu5> PHP Error: Unable to connect to managesieve on localhost:4190 in /usr/share/roundcubemail/plugins/managesieve/lib/Roundcube/rcube_sieve_engine.php on line 216 (GET /roundcubemail/4iQ3Zkic5ceVtrVU/?_task=settings&_action=plugin.managesieve-vacation)
    [13-Jul-2016 20:51:03 UTC] ERROR: Not currently in AUTHORISATION state (1)
    [13-Jul-2016 20:51:03 UTC] ERROR: Not currently in AUTHORISATION state (1)
    [13-Jul-2016 20:51:03 UTC] ERROR: tarttls failed"

    I've checked settings of cyrus and roundcybe-managesieve and everything seems correct. netstat shows that cyrus is active on 4190

    tcp 0 0 0.0.0.0:4190 0.0.0.0:*
    LISTEN 1609/cyrus-master
    tcp6 0 0 :::4190 :::*
    LISTEN 1609/cyrus-master

    Also i'm not sure if my cyrus and guam are correctly configured for work with ssl:
    *sslscan --no-failed localhost:993 *output seems good, but there a message in the end of output:

    Verify Certificate:
    unable to get local issuer certificate

    Thank you for your suggestions!

    Best regards,
    Iman Nuraev



  • @imnnrv said:

    PHP Warning: stream_socket_enable_crypto(): SSL operation failed with code 1. OpenSSL Error messages:
    error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number

    Seems an issue with the LetsEncrypt setup? This is usually because SSL is not actually available ...



  • After the clean install and some experiments everything works.
    Thank you for your response!



  • Awesome! Glad you could get it resolved...